#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)"
Local $sString = "1,,,4"
Local $sSubst = "\1;\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)