const regex = /^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\d+)|),(?:(\\d+)|),(?:(\\d+)|),(?:(\\d+)|)', 'gm')
const str = `1,,,4`;
const subst = `\1;\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);