const regex = new RegExp('(?:lazy_)?ngtxt\\(([\\"\\\\'])((?:(?!\\1)[^\\\\]|\\\\.)+)\\1,\\s*([\\"\\\\'])((?:(?!\\3)[^\\\\]|\\\\.)+)\\3,\\s*(?:.+?)\\)', 'gm')
const str = `* ngtxt('i am in single-quotes', 'i am in single-quotes 2', foo)
* ngtxt('i have \\' an escaped single-quote within single-quotes', 'i have \\' an escaped single-quote within single-quotes 2', foo)
* ngtxt('i have a "double-quote" in single-quotes', 'i have a "double-quote" in single-quotes 2', foo)
* ngtxt("i am in double-quotes", "i am in double-quotes 2", foo)
* ngtxt("i am in double-quotes with single 'quotes'", "i am in double-quotes with single 'quotes' 2", foo)
* ngtxt('i have an escaped double-quote \\" within double-quotes', 'i have an escaped double-quote \\" within double-quotes 2', foo)
* ngtxt('i am singular in single-quotes', "i am plural in double-quotes", foo)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}