# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[0\D]+//mg;t' <<< "DE73456
DE71238
FR00034
FR00036
ES00038
US00039
DE00098"