#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[0\D]+"
Local $sString = "DE73456" & @CRLF & _
"DE71238" & @CRLF & _
"FR00034" & @CRLF & _
"FR00036" & @CRLF & _
"ES00038" & @CRLF & _
"US00039" & @CRLF & _
"DE00098"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)