use strict;
my $str = 'DE73456
DE71238
FR00034
FR00036
ES00038
US00039
DE00098';
my $regex = qr/^[0\D]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";