package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*--\/-(.*?)--\/--\s*`)
var str = `--/--RedorDead :--/-- Tottenham are the worst team in existence --/--RedorDead :--/-- Tottenham are the worst team in existence`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}