re = /^((0[1-9]|1[0-2])|([1-9]{1}))\/([0-9]{4}|[0-9]{2})$/m
str = '02/13
0213
022013
02/2013
02/20
02/2
02/2032'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end