// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((0[1-9]|1[0-2])|([1-9]{1}))\/([0-9]{4}|[0-9]{2})$").unwrap();
let string = "02/13
0213
022013
02/2013
02/20
02/2
02/2032";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}