package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bsource(?::|=)(?:"(?P<value1>[^"]+)"|(?P<value2>\S+))`)
var str = `... source="source name with quotes - special characters also" ...
... source=source_name_without_quotes_with_special-characters* ...
... source="source_name_with_quotes_no_spaces-*" ...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}