using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])(?=.*\d).{8,}$";
string input = @"JavaScript正则表达式
要求:所有字符都可以输入,但是必须含有字母(不区分大小写)和数字,且总长度不低于8位
sldkfjfl798kl
看来数据打分了
ksdfjdkf的路口附近8
路上的风景&*(+j8
jsdlfkjfdLKJLK
123456789
687678987Kh";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}