const regex = /^(?=.*[a-zA-Z])(?=.*\d).{8,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-zA-Z])(?=.*\\d).{8,}$', 'gm')
const str = `JavaScript正则表达式
要求:所有字符都可以输入,但是必须含有字母(不区分大小写)和数字,且总长度不低于8位
sldkfjfl798kl
看来数据打分了
ksdfjdkf的路口附近8
路上的风景&*(+j8
jsdlfkjfdLKJLK
123456789
687678987Kh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}