$re = '/P0{5}(\d{4}):(.+)/m';
$str = 'P000004245:TESTING THIS NC STRING
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);