#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[expr\s+)([^}][^\]]*)(\])"
Local $sString = "set a [expr $sumy+1]" & @CRLF & _
"set b [[expr $sumy+1] [expr $sumy+2] [expr $sumy+3]]" & @CRLF & _
"set c [expr $sumy+[lindex $coords 1]]" & @CRLF & _
"set d [expr [lindex [$ret] 2] + $Alpha]" & @CRLF & _
"set e [string range $SECNAME 0 [expr [string first - $SECNAME] -1] ]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(\[expr\s+)([^}][^\]]*)(\])" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")