$re = '/\b(?:skewY?|rotate|matrix)\(([^()]+)\)/m';
$str = 'skew(1deg)
rotate(3)
skewY(10deg)
matrix(0, 0, 0, 0, 0, 0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);