use strict;
my $str = 'john.doe@gmail.com';
my $regex = qr/(?<=.).(?=[^@]*?@)/p;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";