// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)^
# Validate the basic structure
(?=\d{1,4}\/\d{1,4}\/\d{1,4}$)
# The below subexpression matches a leap year
# This will be useful later when checking Feb 29th
(?<leap>0*$|\d*(?:[13579][26]|(?:\b|[02468])[048])(?:00|(?<!00))$){0}
# Match and capture a month, saving a 30-day month or Feb for later reference
0*(?<month>(?<thirty>9|4|6|11)|(?<feb>2)|1[02]|[13578])\/
# If Feb was matched and 29 appears, check for a leap year
0*(?<day>[1-9]|1\d|2[0-8]|(?(feb)29(?=\/(?&leap))|(?:29|(?(thirty)30|3[01]))))\/
# Match and capture a year
(?:0\B)*(?<year>\d+)
$").unwrap();
let string = "1/25/2018
3/11/2119
6/8/224
6/54/1996
2/29/2004
2/29/1900";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}