const regex = new RegExp('^(?:[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+)+$', 'gm')
const str = `username
user_name
user.name
user.name_123
username\$\$\$
_username
username_
user_.name
user._name
user__name
user..name
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}