package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\d{1,3})).\d{1,3}.\d{1,3}){1}.*
`)
var str = `
Matches:
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR LAS 1.01.01 4P Postfix
MR LAS E.01.01 4P Kürbis Postfix
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR x LAS 1.01.01 4P
Fails:
MR LAS 1.A.1 4P
MR LAS A..1 4P
MR LAS x1.01.01 4P
MR LAS 1.x.01 4P
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}