import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\\d{1,3})).\\d{1,3}.\\d{1,3}){1}.*\n";
final String string = "\n"
+ "Matches:\n"
+ "MR LAS 1.1.1 4P\n"
+ "MR LAS A.0.1 4P\n"
+ "MR LAS 1.01.01 4P\n"
+ "Prefix MR LAS 1.01.01 4P\n"
+ "Prefix MR LAS E.01.01 4P Kürbis\n"
+ "MR LAS 1.01.01 4P Postfix\n"
+ "MR LAS E.01.01 4P Kürbis Postfix\n"
+ "Prefix MR LAS 1.01.01 4P\n"
+ "Prefix MR LAS E.01.01 4P Kürbis\n"
+ "MR x LAS 1.01.01 4P\n\n"
+ "Fails:\n"
+ "MR LAS 1.A.1 4P\n"
+ "MR LAS A..1 4P\n"
+ "MR LAS x1.01.01 4P\n"
+ "MR LAS 1.x.01 4P\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}