use strict;
my $str = 'banana | 10';
my $regex = qr/(\|[^\S\n]*)\d+/mp;
my $subst = '\\g<1>9';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";