$re = '/(\|[^\S\n]*)\d+/m';
$str = 'banana | 10';
$subst = "\g<1>9";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;