// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\|[^\S\n]*)\d+").unwrap();
let string = "banana | 10";
let substitution = "\\g<1>9";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}