use strict;
my $str = 'abcd-12=jksjd-jkkj-kjk
xyzm-87=hjahf-tyewg-766-gffg
zaqw-99=poiuy-12hd-0909-iuy';
my $regex = qr/(=[^-\r\n]+)-/mp;
my $subst = '\\1_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";