// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:(?'cle1'.+?) : (?'valeur1'.+))|(?:(?'cle2'.+?) : )|(?: : (?'valeur2'.+))|(?'etc'\.\.\.|…)|(?'cle3'.+))$").unwrap();
let string = "Cooper Koch : Erik Menéndez
Nicholas Alexander Chavez :
Nathan Lane
: Dominick Dunne
...
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}