re = /((?<!gf_)apply_filters|do_action).*?\( ?('|")(.*?)('|").*/m
str = 'apply_filters( \'gform_export_separator\', \',\', $form_id );
do_action( \'gform_export_separator\', \',\', $form_id );'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end