// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((((?<QT_days>\d+)d)?(?<QT_hours>\d+)h)?(?<QT_minutes>\d+)m)?(?<QT_seconds>\d+)s").unwrap();
let string = "1d2h3m4s
4h55m6s
12m34s
21s";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}