import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ((?:#[\\w\\d\\-\\_\\ \\t]*)+)(@[\\w\\d\\-\\_\\.\\,\\!\\?\\ \\t\\:\\;\\%\\+\\(\\)\\\\\\/\\'\\\"\\`\\%\\$]*)?$";
final String string = "ls -la #\n"
+ "ls -la #1\n"
+ "ls -la #2#2\n"
+ "ls -la #1#2#3 @München\n"
+ "ls -la #1# 2#3 @München\n"
+ "ls -la #1# 2 #3 @München\n"
+ "ls -la #1#2 @desc \n"
+ "ls -la #@desc \n"
+ "echo \\#toignore #1\n"
+ "echo \"#toignore\" #1-2\n"
+ "echo \"#toignore\" #@desc\n"
+ "ls -la#toignore\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}