use strict;
my $str = 'ls -la #
ls -la #1
ls -la #2#2
ls -la #1#2#3 @München
ls -la #1# 2#3 @München
ls -la #1# 2 #3 @München
ls -la #1#2 @desc
ls -la #@desc
echo \\#toignore #1
echo "#toignore" #1-2
echo "#toignore" #@desc
ls -la#toignore
';
my $regex = qr/ ((?:#[\w\d\-\_\ \t]*)+)(@[\w\d\-\_\.\,\!\?\ \t\:\;\%\+\(\)\\\/\'\"\`\%\$]*)?$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}