import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^PAT_A_[^;\\n]*(?:\\n(?![^\\n;]*NOT_MATCH_THIS)[^;\\n]*)*\\n[^;\\n]*PAT_B.*(?:[^;]*);";
final String string = "PAT_A_YYY(\n"
+ " OK,\n"
+ " PAT_B\n"
+ ");\n\n"
+ "PAT_A_XXX(\n"
+ " NOT_MATCH_THIS,\n"
+ " PAT_B\n"
+ ");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}