$re = '/^PAT_A_[^;\n]*(?:\n(?![^\n;]*NOT_MATCH_THIS)[^;\n]*)*\n[^;\n]*PAT_B.*(?:[^;]*);/m';
$str = 'PAT_A_YYY(
OK,
PAT_B
);
PAT_A_XXX(
NOT_MATCH_THIS,
PAT_B
);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);