re = /^PAT_A_[^;\n]*(?:\n(?![^\n;]*NOT_MATCH_THIS)[^;\n]*)*\n[^;\n]*PAT_B.*(?:[^;]*);/m
str = 'PAT_A_YYY(
OK,
PAT_B
);
PAT_A_XXX(
NOT_MATCH_THIS,
PAT_B
);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end