re = /(?<=\d{2}N)[\S\s]*?(?=NONREF)/m
str = '221222DY1356,63NCCPNONREF
221222DY1356,63NTRFNONREF
221222DY1356,63NEFTNONREF
221222DY1356,63NMSCNONREF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end