package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^,]+,\"city\":\"(?<city>[^\"]+)\",\"state\":\"(?<state>[^\"]+)`)
var str = `12345 noth test Avenue","city":"test","state":"test",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}