using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>\b[\w-]+\b)=(?<delimiter>[""'])(?<value>.*?)(?&delimiter)";
string input = @"IP-Address=""192.168.0.0"" Servername=""UA Local Discovery Server"" Rechnername=""WG-DE-D11001DS"" Comment=""Lokaler OPC-UA Server"" Type=""SimaticNET.S7"" Company=""Coperion"" IntValue='45'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}