const regex = /(?<name>\b[\w-]+\b)=(?<delimiter>["'])(?<value>.*?)(?&delimiter)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>\\b[\\w-]+\\b)=(?<delimiter>["\'])(?<value>.*?)(?&delimiter)', 'gm')
const str = `IP-Address="192.168.0.0" Servername="UA Local Discovery Server" Rechnername="WG-DE-D11001DS" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" IntValue='45'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}