import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Entre\\ssemana|El\\sfin\\sde\\ssemana)\\s([A-Z][a-z]+?)\\s([A-Z][a-z]+?)\\s([A-Z][a-z]+?)\\s([A-Z][a-z]+?)\\sse\\sacuesta\\sa\\slas\\s([0-9]{2}\\:[0-9]{2}\\s)(am|pm)\\sy\\sse\\slevanta\\sa\\slas\\s([0-9]{2}\\:[0-9]{2}\\s)(am|pm).*$";
final String string = "Entre semana Juan Miguel Rangel Moncada se acuesta a las 8 pm y se levanta a las 08 am.\n"
+ "Entre semana Jorge Enrique Canon Pinzon se acuesta a las 9 pm y se levanta a las 3 am.\n"
+ "El fin de semana Maria Lucia Espitia Lovera se acuesta a las 7 pm y se levanta a las 12 pm.\n"
+ "El fin de semana Yesid Alexander Munoz Lozano se acuesta a las 10 pm y se levanta a las 5 am.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}