use strict;
my $str = 'Entre semana Juan Miguel Rangel Moncada se acuesta a las 8 pm y se levanta a las 08 am.
Entre semana Jorge Enrique Canon Pinzon se acuesta a las 9 pm y se levanta a las 3 am.
El fin de semana Maria Lucia Espitia Lovera se acuesta a las 7 pm y se levanta a las 12 pm.
El fin de semana Yesid Alexander Munoz Lozano se acuesta a las 10 pm y se levanta a las 5 am.';
my $regex = qr/^(Entre\ssemana|El\sfin\sde\ssemana)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\sse\sacuesta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm)\sy\sse\slevanta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}