import Foundation
let pattern = #"^(Entre\ssemana|El\sfin\sde\ssemana)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\s([A-Z][a-z]+?)\sse\sacuesta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm)\sy\sse\slevanta\sa\slas\s([0-9]{2}\:[0-9]{2}\s)(am|pm).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Entre semana Juan Miguel Rangel Moncada se acuesta a las 8 pm y se levanta a las 08 am.
Entre semana Jorge Enrique Canon Pinzon se acuesta a las 9 pm y se levanta a las 3 am.
El fin de semana Maria Lucia Espitia Lovera se acuesta a las 7 pm y se levanta a las 12 pm.
El fin de semana Yesid Alexander Munoz Lozano se acuesta a las 10 pm y se levanta a las 5 am.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)