package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w]{0,100})@([\w]+)\.([\w]+)`)
var str = `_saffewf1243214ffw@asdqq.rr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}