#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:" & @CRLF & _
" (^(?:[^\nA-Z]+-)?)" & @CRLF & _
"|" & @CRLF & _
" ((?:-[^\nA-Z]+|(?<![^\nA-Z]))$)" & @CRLF & _
"|" & @CRLF & _
" ((?:[^\nA-Z]*)?[A-Z])" & @CRLF & _
")"
Local $sString = "foo-ABcmCD-bar" & @CRLF & _
"DEF" & @CRLF & _
"WHATEVER-foo" & @CRLF & _
"foo-ABC-bar" & @CRLF & _
"ABC-bar" & @CRLF & _
"ABcmC" & @CRLF & _
"foo-abCD" & @CRLF & _
"abCD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")