# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^@[^{]+\{([^,]+),"
test_str = ("@Article{m2023a,\n"
" author = {S. Macdonald},\n"
" journal = {Social Science Information},\n"
" title = {The gaming of citation and authorship in academic journals: a warning from medicine},\n"
" year = {2023},\n"
" doi = {10.1177/05390184221142218},\n"
" issue = {In Press},\n"
"}\n\n"
"@Misc{b2017a,\n"
" author = {S. Buranyi},\n"
" title = {Is the staggeringly profitable business of scientific publishing bad for science?},\n"
" year = {2017},\n"
" journal = {The Guardian, 27 June 2017},\n"
" url = {https://www.theguardian.com/science/2017/jun/27/profitable-business-scientific-publishing-bad-for-science},\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.