# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"transactionId=(?<transactionId>.*?)}.*ResourceId:\s(?<featureName>.*?),.*CPNYID_(?<companyId>\d+)_AID_(?<aPaymentId>\d+)"
test_str = "2020-Apr-10 09:32:50.086 PDT [pool-4-thread-1] INFO com.adp.taxmod.lock.service.NTLockServiceImpl {createdDate=Fri Apr 10 09:32:49 PDT 2020, id=4-699211, transactionId=3746ddf0-e602-409b-831c-d0cd995c5595} - NTLockServiceImpl : acquireLock() - ResourceId: CREDIT_RECONCILE, ResourceType: {} CPNYID_25817065_AID_996"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.