$re = '/\b\w+(?=\s*[,()])/m';
$str = 'MethodName(int? Property1, string Property2, List<int?> Property3)
MethodName (int? Property1 , string Property2, List<int?> Property3)
MethodName()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);