#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\|-+\|(?:[\r\n]+|$)"
Local $sString = "^ A ^ B ^ C ^" & @CRLF & _
"|-----------|" & @CRLF & _
"Ignore this line" & @CRLF & _
"| And | Ignore | This |" & @CRLF & _
"^ D ^ E ^ F ^ G ^" & @CRLF & _
"|---------------|"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)