package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Failed password for(?: invalid user)? .+ from (?<ipAddress>(?:\d{1,3}\.){3}\d{1,3}) port \d{1,5} ssh\d?$`)
var str = `Failed password for invalid user foo bar from 192.168.1.7 port 49721 ssh2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}