#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(000[1-9]|00[1-9]\d|0[1-9]\d\d|100\d|10[1-9]\d|1[1-9]\d{2}|[2-9]\d{3}|[1-9]\d{4}|1\d{5}|2[0-6]\d{4}|27[0-4]\d{3}|275[0-6]\d{2}|2757[0-5]\d|275760)-W(([1-4]\d)|(5[0-3])|0[1-9])$"
Local $sString = "min possible year :" & @CRLF & _
"0001-W10" & @CRLF & _
"" & @CRLF & _
"max possible year :" & @CRLF & _
"275760-W05" & @CRLF & _
"" & @CRLF & _
"min possible week :" & @CRLF & _
"1969-W01" & @CRLF & _
"" & @CRLF & _
"max possible week :" & @CRLF & _
"1969-W53" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1-W$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)