$re = '/(?<!(東京|大阪))(?<!(北海道|神奈川))特許事務所/m';
$str = '東京特許事務所
大阪特許事務所
北海道特許事務所
神奈川特許事務所
群馬特許事務所';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);