import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "USER \\((\\w+)\\)$";
final String string = "Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)\n"
+ "show_time_of_pid(\"Jul 6 14:02:08 computer.name jam_tag=psim[29187]: (UUID:006)\n"
+ "Jul 6 14:02:09 computer.name jam_tag=psim[29187]: (UUID:007)\n"
+ "Jul 6 14:03:01 computer.name CRON[29440]: USER (naughty_user)\n"
+ "Jul 6 14:03:40 computer.name cacheclient[29807]: start syncing from \\\"0xDEADBEEF\\\"\n"
+ "Jul 6 14:04:01 computer.name CRON[29440]: USER (naughty_user)\n"
+ "Jul 6 14:05:01 computer.name CRON[29440]: USER (naughty_user)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}