$re = '/^(wss?:\/\/)([0-9]{1,3}(?:\.[0-9]{1,3}){3}|[^\/]+):([0-9]{1,5})$/m';
$str = 'ws://0.0.0.0:8080
wss://192.168.0.25:12345
ws://localhost-and-oth3r-chars:3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);